Another kl 600 project head thumper - Kawasaki KLR 650 Forum
Other KLR's - 250, 600, Tengai, C Models, KLX... Discussion of all the OTHER KLR models.

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 01-15-2014, 04:30 PM Thread Starter
Neutral
 
Join Date: Jan 2014
Posts: 2
Another kl 600 project head thumper

Hey all. New to the forum hoping for some insight maybe into my new project. Just picked myself up a 85 kl600 not running and in a few pieces. Plastics look fairly decent and actually in over all good condition. Clutch lever was broke and front brake master cylinder was seized. All that was a piece of cake and not im getting stumped.

The wiring was messed with a bit (definatly not my strong suit to play with wiring) and the start/stop button was smashed and wrecked. So now im coming up with the task of re wiring that. I got myself a start/stop button combo off of a 08 klr 650 and figured id be able to wire that in. The harness from the 85 is a 5 wire harness and the harness from the 08 is a 4 wire. So I peeled the covers off so I could see where all the wires splice into each other and put the old connector on the new switch. But when I go to hit the go button, nothing. I have a good battery and lights and everything light up in the instrument cluster but nothing when I hit the start button. Wondering if this could be clutch lever safety switch or seomthing else. Starter turns when I jump the soloniod so I know its good. But absolutely nothing happens when I hit that go button. Any ideas? thanks in advance.
christack44 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 01-26-2014, 10:38 AM Thread Starter
Neutral
 
Join Date: Jan 2014
Posts: 2
well I think I got it all figured out. only question now is are you supposed to have the rear turn signals as running lights. the signals work properly. but just key on bike off there are no running lights on them and no wires seem to bring running light power back there. little confused by this. also my brights work on my headlight and my dims don't. and I just put in a brand new bulb so its not that. ideas?????
christack44 is offline  
post #3 of 4 Old 01-26-2014, 06:13 PM
1st Gear
 
Join Date: Oct 2012
Location: Georgia
Posts: 47
The turn signals on the KL600 are single filament bulbs. They are turn signals only.
Maico88 is offline  
 
post #4 of 4 Old 02-07-2014, 04:37 PM
1st Gear
 
hellboy7's Avatar
 
Join Date: Jan 2014
Posts: 15
You might as well just use the opportunity now to change them out to LED.... they have to be out judging by what you're saying.
hellboy7 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
KLR 600 Cylinder head Millhouse 1987 to 2007 Wrenching & Mods 32 10-17-2013 11:09 AM
Firing up an old thumper? Savage KLR & Other Motorcycle Related Discussion 42 10-05-2012 11:25 PM
FSSNOC Thumper Cafe webmost KLR & Other Motorcycle Related Discussion 1 05-11-2010 04:13 PM
My project... Blackegg Show Off Your Bike 7 04-16-2008 09:51 AM
My first Thumper........ Idealgiant 1987 to 2007 Wrenching & Mods 3 10-23-2007 10:30 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome