1986 KLR600 wont start - Kawasaki KLR 650 Forum
Other KLR's - 250, 600, Tengai, C Models, KLX... Discussion of all the OTHER KLR models.

 2Likes
  • 1 Post By pdwestman
  • 1 Post By pdwestman
 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 04-08-2017, 05:18 AM Thread Starter
Neutral
 
Join Date: Apr 2017
Posts: 8
1986 KLR600 wont start

Hi- thanks for the info and links that have been sent to me already, some questions to ask of the forum if that's ok, I bought my bike as a none runner, the previous owner had it running but it just stopped one day. he tracked it to the CDI unit and put another one on, it ran after that but then stopped again. I am in the process of chasing faults by checking everything, I seem to have no spark is one issue, the question I have is that my bike has no start button, the run/kill switch is the start switch, is this normal? my bike has a kick start, did they come with both in 86? has my starter been added on as a mod? should I add a start button? thanks Dave
DAS68 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 04-08-2017, 09:54 AM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,239
DAS68,
No Starter Button on the RH switch assembly?
I'll guess that maybe you actually own a 1984 KL600-A1, kickstart only model?

In the USA, the VIN stamped into the steering neck is encoded with the year model. The White & Black sticker next to it has the model name/number and the month/year of production. Please supply those numbers.
You may be able to find a site to decode the UK VIN, like we have in the states.

Also the Yuasa battery number/size would be an indicator.
1984 kickstart only, YB4L-A / 1985-86 electric start, YB14L-A2.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is offline  
post #3 of 10 Old 04-08-2017, 10:23 AM Thread Starter
Neutral
 
Join Date: Apr 2017
Posts: 8
Yes no start button on the right side just the engine run button that is wired to turn it over. The vin says klr600b007914, the v5 says regestered 11.04.2003 (decl/d manuf 1986)
DAS68 is offline  
 
post #4 of 10 Old 04-08-2017, 12:09 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,239
klr600B is the Electric start model, alright.
Google this part # 27045-1052, switch assembly. It is the kill switch/starter button/mirror mount, complete. Still available in the USA, about $70.
DAS68 likes this.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is offline  
post #5 of 10 Old 04-08-2017, 12:29 PM Thread Starter
Neutral
 
Join Date: Apr 2017
Posts: 8
Quote:
Originally Posted by pdwestman View Post
klr600B is the Electric start model, alright.

Google this part # 27045-1052, switch assembly. It is the kill switch/starter button/mirror mount, complete. Still available in the USA, about $70.


They won't ship outside the sates


Sent from my iPhone using Tapatalk
DAS68 is offline  
post #6 of 10 Old 04-08-2017, 02:20 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,239
Quote:
Originally Posted by DAS68 View Post
They won't ship outside the sates


Sent from my iPhone using Tapatalk
I would suggest that you can purchase that part # from a UK Kawasaki dealership or used from a salvage yard.

Did you find a pic?

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting
pdwestman is offline  
post #7 of 10 Old 04-08-2017, 03:05 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,239
This link has a pic,
https://www.google.com/search?q=Kawa...294PM:&spf=191

27045-1052 also fits (Gen1) KLR650.
DAS68 likes this.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 84,000+ miles & counting

Last edited by pdwestman; 04-08-2017 at 03:29 PM. Reason: Gen 1
pdwestman is offline  
post #8 of 10 Old 04-09-2017, 04:44 AM Thread Starter
Neutral
 
Join Date: Apr 2017
Posts: 8
cheers, if I cant find a KLR switch will others work so long as the connection on the wires are the same or can be re-attached?also, when I turn the ignition on and out the headlight on there is smoke coming from the wiring, near the battery negative lead I think, and some of the block connectors are very hot.
DAS68 is offline  
post #9 of 10 Old 04-09-2017, 12:28 PM Thread Starter
Neutral
 
Join Date: Apr 2017
Posts: 8
I am trying to test my coil but there is only one terminal on the primary side so not sure how I can test it with a multimeter? also I am looking for a wiring harness if anyone has one to sell, will a 650 loom fit a 600?
DAS68 is offline  
post #10 of 10 Old 04-11-2017, 09:43 AM Thread Starter
Neutral
 
Join Date: Apr 2017
Posts: 8
Hi all, my wires are a mess so I am looking or a loom, I've found one in Germany but before I purchase it can anyone tell me if it will fit my bike, its advertised as the following word for word, Cable loom, Kawasaki KLR 650 KLR 650 600 KLX built around about 1989.
DAS68 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
01 wont start Beardyman 1987 to 2007 Wrenching & Mods 8 05-02-2012 08:09 AM
wont start!! help!! wnc/mtn=klr 1987 to 2007 Wrenching & Mods 7 04-29-2012 07:35 PM
1986 klr650 won't start dlh 1987 to 2007 Wrenching & Mods 7 01-29-2011 11:11 PM
bike wont start TEXAS 650 1987 to 2007 Wrenching & Mods 20 05-18-2008 06:09 PM
Bike wont start blprince 1987 to 2007 Wrenching & Mods 6 07-25-2007 07:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome