Running issues - Kawasaki KLR 650 Forum
Other KLR's - 250, 600, Tengai, C Models, KLX... Discussion of all the OTHER KLR models.

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-17-2019, 04:54 AM Thread Starter
Neutral
 
Join Date: Jun 2018
Posts: 2
Running issues

Guys,

Looking for some advice on my Klr 600. Bike has been running terribly since I have had it, got the carbs cleaned and a new carb kit for it. Had the fuel tank cleaned and treated and a new coil fitted. However when I try to ride it the bike splutters under load like itís not getting fuel. The petcock was removed and cleaned so I canít think what could be the issue. Is there a chance that this could be electrical and if so where would I start? Secondly it is terribly smoky which I would suspect is burning oil, is this a major issue to fix and where can I get parts?

Many thanks for any help.
Alex Wood is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 02-17-2019, 03:29 PM
OverDrive
 
Join Date: Nov 2009
Location: Lander, Wyoming
Posts: 5,624
If the fuel petcock can flow 32 oz/1L in 10 minutes or less that is Not the problem.

Is your carburetor missing the Needle JET, which surrounds the jet NEEDLE and sticks Up about 5mm into the throat of the carb?

Is your throttle slide Diaphragm chaffed thru, torn, pinched, twisted?

Is the white plastic spring guide Under or Above the Jet Needle?

The BLUE Hi-lighted Link to text and the 4 excellent videos included in this link to a thread should straighten out any carburation issues.

https://www.klrforum.com/how-tos-tec...ing-cvk40.html.

pdwestman
Modify at "YOUR OWN RISK"!

Still riding my 1987 KL650-A1. 85,000+ miles & counting
pdwestman is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki KLR 650 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
08 K.l.r. Stopped Running masterofsparks KLR & Other Motorcycle Related Discussion 4 06-13-2008 03:58 PM
running to purdue bay nesretep08 Alaska & Hawaii Riders 2 11-02-2007 03:58 PM
Starting on choke wont stay running posgnd 1987 to 2007 Wrenching & Mods 7 05-04-2007 06:44 AM
A question for those running the EBC 320mm rotor and pads> BenzTech 1987 to 2007 Wrenching & Mods 20 10-23-2006 07:07 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome