Kawasaki KLR Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hello All,
2011 recently developed a charging issue at 9200 miles, I replaced doohickey at 8200 miles with no issues and thermo bob done at 9000 miles with a 16t sprocket. Today key was left on for about 5 min, bike was push started and on way home would cut ignition when blinkers or high beams applied. New AGM battery installed and shows 12.6 volts engine running at 2000 rpm. I had a low beam headlight blow out about 2 weeks ago and read one forum that suggested that was a symptom of a bad regulator.
Question:
Should I now start with a regulator? Is there any way to test one on a bench?
Sorry if this question has been previously answered but I couldn't find it searching.
Wires near sprocket from stator have been visually inspected but wire sheath was not cut free to see under the sleeve.

Thanks for any and all advice,
Logan
 

· Registered
Joined
·
28 Posts
Discussion Starter · #5 ·
Thanks to all, video is very helpful. Trying to get the bike rolling for a camping trip this coming weekend and won't have time for Clymer manual to get here. New regulator should be here tomorrow, hopeful.
The three yellow wires when tested at the regulator were 5v, 48v, and 7v. I have no idea if those are normal numbers or not, hard to find much info as KLR's don't seem to break down that often.
 

· Registered
Joined
·
28 Posts
Discussion Starter · #7 ·
This would be one of those cases where you can explain it to me, but you can't make me understand. Electrical is not my thing, though I accept your superior knowledge on the subject and was able to order a new stator off ebay with returns available.
For clarity, there should be no continuity between ground and the 3 yellow wires from stator and there should be voltage between paired wires on the regulator connnector?
Not trying to be difficult, just in over my head and learning as I go.
I did pop the stator cover off and inspect wires with no visible defects.
Thanks again and sorry if this isn't clicking for me.
 
1 - 3 of 3 Posts
Top