Kawasaki KLR Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hey guys I just got my first motorcycle which happens to be a klr and I could not be more excited. I am an engineer and like to think I am pretty handy but there are a lot of things for me to learn about a bike. (Last week was the carb cause it had been in storage for awhile). Anyways now the horn and headlamp are finicky. Sometimes they work and sometimes they don't. I'm assuming this is just a loose connection somewhere but I figured id make a post and see if it's a common/simple fix. Thanks in advance for any help!
 

·
Registered
Joined
·
1,256 Posts
The horn switch and the head light switch are mostly unrelated because their power flows in different direction from the ignition switch. they do both share the same connector form the left handlebar sub harness to the main wiring harness.

The horn is wired hot and the switch make a ground for it. The low beam is wired hot all the time and switch jumps the high beam circuit to the low beam circuit to bring on the high beam. Describe the finiky actions.

Here is a wiring diagram that should help. http://www.klr650.net/forums/attachment.php?attachmentid=26023&d=1251918868
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3 (Edited by Moderator)
Thanks! I think I'm going to look into the connection off the left handlebar. The finicky actions are just that sometimes they work and sometimes they don't. Once I hit the horn and it kinda fiddled out and then didn't work. I'm hoping it's just a loose connection off the left side but the turn signals work fine so maybe they aren't connected?
 
1 - 4 of 4 Posts
Top