Kawasaki KLR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
241 Posts
Discussion Starter #1
Just changed my low beam today.
Owned the bike little over a month and half, all lights worked when I bought it. (used with 18,000, 21,000 now)
I have burned out license plate light, all 3 dash bulbs, low beam, tail light.
Does not seem to be over-charging (14.4 volt)

Is this normal?
Been replacing with LEDs except low beam.

Is this a effect of running at 5800-6200 rpm's on the highway for 300 miles at a time?

Gordon
 

·
Administrator
Joined
·
8,244 Posts
That's about normal for an H7. I just went through maintenance on my RT and, on the warm-up ride up and down the block in my shorts, tank top and flip flops, one of the low beams went out.

They seem to last several hundred hours. The 'normal' brightness last longer than the 'ultra-bright'.

On the RT they go out in pairs (within a day's riding time of one another), so I replaced both low beams.

No worries.

Tom
 

·
Registered
Joined
·
1,260 Posts
The tail light is on all the time and gets a lot of vibration back there and you almost never see it unless you check on purpose. The same for the license, low beam and the three dash instrument lights.

I replace all the above with LEDs and also the three dash indicator lights also while I am in there.

I have 100K miles on turn signals, neutral, high beam indicator and signal indicator with no loss.

LED headlights will last longer and be brighter. I think you get the ones with a reflector cup/dish built around the element to help keep the light from going up in the trees and out in the bushes.
 

·
Registered
Joined
·
241 Posts
Discussion Starter #5
turn signals, neutral, high beam indicator and signal indicator with no loss.
I haven't lose any of the above, same as you.
May try LED headlight next time.
Sound like mine is normal.

Thank you..
 
1 - 5 of 5 Posts
Top