Kawasaki KLR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everybody, my name is Louis-Mathieu and this is my first post. I assume the subject has been covered over and over but I can't get my bike to run good again after I touched the carb so I'm looking for help!

Here is my story so far: Bought a completely original 2005 Klr 650 at the end of the season last year with 11 500 kilometers. I did 1500 kms and the bike was running great when I stored it for the winter.

At the beginning of the season, I took the bike out, changed the oil and cleaned the air filter.

The bike was running great but on the highway it would miss a little bit when going above 100 km/h. I tought maybe the carb was dirty so I took it apart only to find out it was clean and that I had forgot a rag in the airbox (Yeah I know...)

Since I had remove the gas tank, I replaced the spark plug but the one that was in place was dry and a good brown color.

During the process, I broke two plastic choke housings but now it's been replaced with a new one.

So I've pulled the carb out three times, cleaned everything with carb cleaner and compressed air, replaced the spark plug, removed the rag I had forgot in the air box but now the bike won't run well.

It will start and idle, with and without choke, will rev to 3000 rpms with choke on and no throttle.

But as soon as I turn the throttle a bit, the bike will have a hard time to rev and will die 2 seconds after most of the times, and sometimes if I close the throttle quiclkly it will get back to idle. If I turn the throttle quickly to 3/4 it will reach 4000 rpms and will get back to idle after not without difficulty though. The spark plug is now black in comparison of brown before I remove the carb to clean it.

Here is everything I did so far:

- New spark plug

- Completely disasembled the carburetor three times, ran air and carb cleaner everywhere, checked the main and pilot jet, both were clean.

- Vents from carb to tank is good, petcock functions properly (delivers gas when everything is connected and I press the starter button).

- All vents (black from the tank, transparent orange on the carb are good)

- Tried with gascap open and closed, same result.

- The needle is in good condition

- The diaphragm shows no sign of wear and no holes and I can feel the vacuum when I move the slide although I don't know how much vacuum is proper vacuum...

- Same result with the old spark plug and the new spark plug, now both are black.

Yet at about 1500-2000 rpms, the bike ceases to rev and dies most of the time. Since the bike was running good before I did all of this, I can only assume that this is a carb problem that I created but I am not the best mechanic so I don't know what to look for anymore.

Any suggestions would be appreciated !

Thanks for taking the time to read this and I hope to get back to the trails soon :crying:

Louis-Mathieu
 

·
Premium Member
Joined
·
7,144 Posts
Louis,
I'll almost bet 'dollars to donuts' that you lost the Needle JET.
It is 'silver' in color and it protrudes about 1/8th inch up into the throat of the carburetor, surrounding the Jet NEEDLE.

It is usually the last item removed after the mid-range emulsion tube with the main jet screwed into it is removed. The 'silver' Needle JET is just a 'light' press fit in the carb. It usually fall out when you aren't looking or using compressed air to dry things off.

Click on the blue hi-light of this posting,
http://www.klrforum.com/417642-post1.html

And then click on the blue hi-light of that thread.
I think I even remember a video.
 

·
Premium Member
Joined
·
1,585 Posts
I did something like 9 rebuilds before noticing the STEEL bit that
sits atop the main jet sitting on the garage floor........


It acted the same way as yours. Runs perfect with all the parts in it. Lesson learned.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #5
pdwestman, I owe you a dollar ! Thank you so much for that information. I went to my shop and found the part right there on the floor.

CheapBassTurd, yeah ahah I was getting more and more frustrated by the situation as I felt I was doing everything correctly.

Damocles, thanks for these videos! If someone come to this thread with the same problem as me, the part talking about the Needle Jet is in video #2

See you on the trails!

Louis-Mathieu
 
1 - 5 of 5 Posts
Top