Kawasaki KLR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
335 Posts
Discussion Starter #1
Ok, so I had this slight squeak at low speed when the clutch is engaged. Kinda sounds like a mouse. Then I pull the clutch in and it disappears. I've also noticed it does it when moving the handlebars from side to side. I've found that it is actually the clutch cable rubbing under the ignition. I've lubed the outside of it, but then it just comes back. So I saw on a different forum (blasphemy, I know) that the clutch cable on an 08+ is supposed to be routed through the notched hole on the steering stem. Once you reroute it, then all the squeaking stops. I'm assuming the hole is the one that almost resembles a sideways tear drop. Problem is, I'm not a member of the forum and I cant pull up the pic. Has anyone have any knowledge on this? Here's a link: http://www.klr650.net/forums/showthread.php?t=94141
 

·
Premium Member
Joined
·
6,842 Posts
From what I can tell, he is referring to a 'stiff wire' loop which is welded to the steering neck, just under the base of the ignition switch. Not the side-ways 'tear-drop' in the stamped steel fairing support.

But every Gen2 KLR that I have been around has routed the clutch cable just like yours, and they do squeak.

I think that 'larry31' has addressed this issue, somehow.
'Click' on his name and find his postings!

Oh by the by, membership is just as free over 'there' as it is here. Otherwise, I wouldn't be on either site. But I can NOT post over there (personal issues). But I can read and view pics if I 'key-in'!
 
  • Like
Reactions: Back2Kawi

·
Registered
Joined
·
335 Posts
Discussion Starter #3
From what I can tell, he is referring to a 'stiff wire' loop which is welded to the steering neck, just under the base of the ignition switch. Not the side-ways 'tear-drop' in the stamped steel fairing support.

But every Gen2 KLR that I have been around has routed the clutch cable just like yours, and they do squeak.

I think that 'larry31' has addressed this issue, somehow.
'Click' on his name and find his postings!

Oh by the by, membership is just as free over 'there' as it is here. Otherwise, I wouldn't be on either site. But I can NOT post over there (personal issues). But I can read and view pics if I 'key-in'!
Man, I didn't even see that loop. Thanks! As far as the membership, I have a yahoo email and apparently that isn't allowed over there. Plus I'm sure if I posted a reference to this site, like I just did to theirs, that would be a nono...lol. In the meantime I will check out Larry31's post. Once again, thanks.
 

·
Premium Member
Joined
·
6,842 Posts
Man, I didn't even see that loop. Thanks! As far as the membership, I have a yahoo email and apparently that isn't allowed over there. Plus I'm sure if I posted a reference to this site, like I just did to theirs, that would be a nono...lol. In the meantime I will check out Larry31's post. Once again, thanks.
Back2Kawi,
Scroll to the Very bottom of this page, in similar Threads! Maybe it was 'Bill10' which fixed his squeak!
 
  • Like
Reactions: Back2Kawi
1 - 5 of 5 Posts
Top