Kawasaki KLR Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello fellow members

My bike is now displaying these issue and wonder if someone can guide me:
The lights flicker when bike is running, the tacho needle jumps wildly at idle and the bike is not idling well. Also the hooter hardly emits a sound (or was very faint) and was about to replace when these conditions manifested. I put the battery on a conditioner overnight as I felt it was cranking a little slow and the issues started this morning

Thanks
Russell
 

·
Registered
Joined
·
175 Posts
Welcome Russell, I have heard that the 08 and 09's had an issue with the wiring harness rubbing through and causing issues. Seems that there was a recall?
Search 'wiring harness rub through'. There were certain spots that were known to cause problems and would be the first place to look.
Good luck, electrical problems can be hard to track down .
 

·
Administrator
Joined
·
10,094 Posts
^ this. You should also look at the battery connections to make sure they are tight. Look at the points on the frame where the ground connections to the harness are and make sure they are tight.

The erratic tach is an indication of a poor ground connection.
 
  • Like
Reactions: spectra

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Welcome Russell, I have heard that the 08 and 09's had an issue with the wiring harness rubbing through and causing issues. Seems that there was a recall?
Search 'wiring harness rub through'. There were certain spots that were known to cause problems and would be the first place to look.
Good luck, electrical problems can be hard to track down .
Excellent thanks I found a Youtube video detailing the issues
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top