Kawasaki KLR Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello, my 2018 gen 2 KLR is having the strangest issue, cleaned the carb and installed a new spark plug and now these things happen that were not happening before:

  • When idling on neutral, rpms drop and the bike turns off.
  • When starting the bike with the choke on, the rpms are choppy and they are not consistent, when giving it a little acceleration it turns off completely (Before I could rev it a bit with the choke on)
  • Here is the strangest thing; when I put it in neutral and start jumping on the pegs like to test the suspension; it starts choking and then it turns off completely.

Please help, don't have much mechanical experience and much less in carburetor topics, which seems to be the culprit.
 

· Registered
2002 KLR 650
Joined
·
370 Posts
Sounds like a vacuum leak. Simple things first. Ill fitting rubber boots, loose boot clamps, A cracked vacuum line flexing open from your carb to the fuel pet cock or AIS system.
An excellent video to review to make sure you cleaned your carb correctly. Best of luck.
 

· Registered
Joined
·
639 Posts
I'll go with Tomo and suggest that you may want to revisit your carb, since you've worked on it recently.
You may also want to disconnect your kickstand safety switch, if you haven't done that - that switch is a known issue, and creates all kinds of intermittent and frustrating problems.

Good luck and let us know what you find!
 

· Premium Member
Joined
·
867 Posts
Did you properly set the float height to 17mm +/-2mm from the flange? It sounds as if the needle is either stuck of out of adjustment. Pull the bowl off and verify it's height in the seated position. As well as make sure it's not hanging up.
 
1 - 4 of 4 Posts
Top