Kawasaki KLR Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter #1 (Edited)
I've got a 08 klr 650 with 9000 miles and it rattle's. Thought it was the doohickey. Replaced it with eagle Mike's using the torsion spring, it helped some but the noise is still there. Checked the valves they were perfect, called Eagle Mike told me to Check the front weighted sprocket inside the left cover it looked like new but had just a hair bit of wobble up and down the shaft looks like it has just a tad bit of wear. The sprocket teeth show a little wear but the cam chain sliders and the rollers look good. We put it all back together and made sure it was in time and added mobile 1 20/ 50 oil which seemed to quiten it down some. Do you guys have any idea what else I could check for? The rattle is the worse on the lower left side. It doesn't use oil, smoke, run hot or anything else never seen any metal in the filter.. Is there something I could add to the oil to quiten it down some more? Or is this just a klr thing???
 

·
Registered
Joined
·
335 Posts
Dont know what kind of rattle it is? But mine has a tick. And so did my Versys, and my ZX6R. It's just the CCT. And with time they get louder or quieter as the CCT self adjusts. I can't say for sure that my CCT sound is the rattle you hear, however the CCT is on the left side of the engine.
 

·
Registered
Joined
·
1,636 Posts
Just a long shot, are all the ballancer weighted shafts timed correctly? You know chain links to dots on sprockets etc etc....maybe...???
Have you used the wooden dowel trick to pin point the sound? Place wooden dowl against your ear then place other end on engine like stethescope DR's use.....they even sell a version for mechanics but the dowel will work.
Are all the spacers etc where they should be behind DOO's sprocket? Sometimes that spacer will fall into sump while doing the DOO if you're not careful. Wild shots in the dark here not being there listeing to noise....?
:character00201:
 

·
Registered
Joined
·
50 Posts
Discussion Starter #4
Yes we got the dots and sprockets with the silver links in the chain. With the help of Mike. Dropped the washer but fished it back out! Everything looks good except the front weighted sprocket it moves in and out the shaft like it needs shimming. I think there was only one washer on the front of it behind the circlip. Acts like it needs a couple more. The sound is more like a chain slap rattle. You can't here it until you rev up the motor and it starts to decelerate. Sounds like it gets slack or rattle's. I
 

·
Registered
Joined
·
1,636 Posts
You did do the DOO right, eh..?...just asking....lol...calm down...lol...because the DOO is in that chains system, maybe the torsion spring isn't holding the chain tight enough???? Is it an Eagle Mike torsion spring because I do know they were copied 1 month after he got them on the market! Dual sport plus tried to sell me one saying it was an Eagle Mike spring and it wasn't! Just saying. I would go back in and look at everything under a microscope.....if it were mine that is!
:character00201:
 
1 - 5 of 5 Posts
Top