Kawasaki KLR Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Hi,

I started noticing the strange chain-like noise coming out of mine engine. I tried to fix it up, redoing chain tension on the bottom of the engine. The first time it worked, but after a while noise have returned again and doing readjustment doesn't work since. I made a short video to give you an idea how it sounds like:

I also thought that it can be camshaft chain. I removed the top valve cover and checked it out - looks pretty tight. It's maybe 10mm of free way max. I didn't find any info how it should be in my Kawasaki manual.

Can it be a doohickey? Please, share your ideas.

Cheers
 

·
Premium Member
Joined
·
7,202 Posts
Hi,

I started noticing the strange chain-like noise coming out of mine engine. I tried to fix it up, redoing chain tension on the bottom of the engine. The first time it worked, but after a while noise have returned again and doing readjustment doesn't work since. I made a short video to give you an idea how it sounds like: youtube dot com/watch?v=iq3cMZr5TKM.

I also thought that it can be camshaft chain. I removed the top valve cover and checked it out - looks pretty tight. It's maybe 10mm of free way max. I didn't find any info how it should be in my Kawasaki manual.

Can it be a doohickey? Please, share your ideas.

Cheers
everm1nd,
Check out sooperdoo.com, by our own Tom Schmitz. The second video shows the original 84-90 wimpy lever & spring.

What I think about the balancer lever issue.
 

·
Registered
Joined
·
42 Posts
sounds like chattery valves when the camera gets close to the engine around the 0:08-0:09 mark of that video. Did you adjust the clearances?

You've also got that automatic tensioner on there...maybe think about swapping that out for a manual tensioner? Not that that will immediately fix your problem but I've read a few places it's a good investment.
 
1 - 3 of 3 Posts
Top