Kawasaki KLR Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hey was just reaching out for some advice. Was removing my tank to change the spark plug today after not being able to get it started at all yesterday. Found I might be missing a tank hose, the rear one. Do I need this hose to run right? And if so where the **** did it go!?!? Just bought the bike super cheap a month ago. Help me!
 

Attachments

·
Administrator
Joined
·
8,364 Posts
It's a vacuum operated petcock. The rear hose is a vacuum hose that goes to the manifold fitting between the carb body and the cylinder. No vacuum hose, no fuel delivery. I think it is 4mm vacuum hose.

Here's a picture of the carb fitting. Gen 2 have two ports, one for the AIS and one for the petcock, while Gen 1 only have the one port for the petcock.

 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
Thanks for the response, put everything back together and it started up for me with new spark plug. Still trying to figure out where that hose went, for another day...
 

·
Administrator
Joined
·
8,364 Posts
Doh! Scratch my response, I didn't see your picture. That's the vent for the tank. All it needs is a bit of hose to drop from that fitting down about a foot or so.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #5
Thanks again, will try and pick up a piece of hose to run off of there asap what size hose?
 

·
Registered
Joined
·
1,256 Posts
Thanks again, will try and pick up a piece of hose to run off of there asap what size hose?
It is a 5mm hose. 1/4" should work fine. The tube at the back of the tank is connected through a line in the tank to the drain in the gas cap recess to run spilled gas out the back. The KLR doesn't need it to run.

Look at part #702 here: https://www.kawasakipartsnation.com/oemparts/a/kaw/500b8e1ff8700223e479a016/fuel-tank

You can use this parts fiche to get all sorts of information. Just put your year model in place of my 2011.
 
1 - 6 of 6 Posts
Top