Kawasaki KLR Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
hey all looking for some help to get my bike started
01 with 11k
I bought this not too long ago without much knowledge of the service record
It started up great when I first got it about a month ago
Yesterday first time with issues. I tried to start it up, without success. The longer I tried the less power the bike seemed to get until I just got clicking. I checked the basics, clutch, kickstand, petcock, etc so I dont think its user error. I swapped out the battery but no success. The bike will turn on but when I hit the ignition it just slowly turns and turns. Any ideas? Will be doing some more investigating shortly.
Thanks for any help
 

·
Registered
2018 KLR650
Joined
·
68 Posts
Sounds like battery may not be fully charged or dirty battery connection.

Did you check the battery voltage?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Well I just cleaned the contacts. Now it's a complete no start at all just clicking. Multimeter is reading 10.6... I just bought this battery last night. Last night was able to crank but slow
 

·
Administrator
Joined
·
3,816 Posts
A KLR battery doesn’t have a lot of cold cranking capacity. Whenever I have issues starting a KLR I hook up a booster battery or battery pack to avoid killing the bike battery completely.
 
  • Like
Reactions: Tym and DPelletier

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
Thanks for the help y'all. The advanced auto parts guys gave me a dead battery which threw me off. Went to cyclegear and replaced filled and charged a new battery. Started no problems.
 
1 - 11 of 11 Posts
Top