Kawasaki KLR Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have 2006 klr new to me I have problem with bike cranks great ,but when accelerating it acts as if it has governor on it only gets to 4500 rpm and 60 mph .if I hold throttle pinned for a Few seconds it I will finally kick in like a turbo and runs normal until I let off throttle then goes thru same scenario again. Took carb off slide moves very smoothly with no hang ups, changed fuel filter tank clean new gas and plug. Once it kicks in if I hold the throttle open it will run fine forever ,but as soon as I let off throttle and it slows down same problem. Any ideas of what to look for?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Carb

I don't see how airfter would cause my problem I removed top of carb and found the diaphragm had a piece missing about one inch long on the edge I am thinking it is losing vacuum and not allowing the use and needle to open all the way what do you all think
 

·
Registered
Joined
·
5,567 Posts
I don't see how airfter would cause my problem I removed top of carb and found the diaphragm had a piece missing about one inch long on the edge I am thinking it is losing vacuum and not allowing the use and needle to open all the way what do you all think
Without full diaphragm integrity, and an air-tight seal around the diaphragm perimeter (MUST fit in its groove in the carburetor casting), it ain't gonna run right, Rebounds!

A diaphragm air leak compromises the pressure differential ("vacuum") lifting the slide and needle; unless the slide and needle rise with intake air flow, the main jet will not be uncovered proportionally to produce optimum air/fuel ratio at rpm.

Good explanation from Googling, "Care and Feeding of the CVK40."
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Do you know if you have to buy slide and diaphragm as one peace or can you just replace the rubber part
 

·
Administrator
Joined
·
3,563 Posts
The diaphragm and slide are shown as a single part.

Last I heard Harley dealers sell these cheaper than Kawi.
 

·
Administrator
Joined
·
3,563 Posts

·
Registered
Joined
·
30 Posts
I am having the same issue. Puttin around town and up to 50mph its fine. But when i try to run the highway it seems like it doesnt have any balls. Have to work hard to get anything above 60. I have done the mc mod, removed the snorkle, klx kit, and i run a uni air filter. All mods, except klx kit, were done before this started. I will check my diaphram in the next couple days and let you guys know what i found.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
carb issues

that sounds exactly my problem when i removed the diaphragm it was very flimsy and had a tear around the edge . My theory is that it did not develop enough vacuum to pull slide up to maximum not allowing adequate fuel flow. When i replaced the diaphragm it ran like it should no more problems.
 

·
Registered
Joined
·
30 Posts
Got around to checkin my diaphram on saturday, and sure enough it had 2 small cuts in it. Ordered a diaphram from tpi on monday and recieved it today. Just replaced it and went for a test ride. Her balls are back. Great acceleration and i can go over 60 easily. No more granny ridin for this guy.
 
1 - 12 of 12 Posts
Top