Kawasaki KLR Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,980 Posts
Discussion Starter #1
We tried installing some smaller turn signals on the back of my buddies bike and remove the factory ones. Problem we ran into was that the lights would NOT blink, just stay on. Any ideas what I did wrong? I know you probabaly need more info, but not sure what to say with some questions from you.
 

·
Registered
Joined
·
15 Posts
Re Signals

Hi There, Don't know where you ordered these from, but if it was E-Bay, there is a guy selling the small turn signals & he now notes that he includes a new flasher unit with the lights, as evidently there was a problem with the lights not flashing when they were installed without it. From what I understand, the signal flasher he is now supplying is the same as a car flasher unit. I just ordered a set of small signals from E-Bay & this sounds very similar to the problem some guys were having with the signals this guy first started shipping. Since then,he now includes a flasher. You may want to try a car signal flasher & see if it works


All the best, Russ
 

·
Registered
Joined
·
1,980 Posts
Discussion Starter #3
I was wondering if that might be the issue. We picked these up at Autozone. They are the bullet type lights you might see on trailers, mounting them right under the rear rack on each side.
 

·
Registered
Joined
·
15 Posts
Hi There Again!!
Forgot to mention that the problem was the wattage of the bulbs, not the same as the originals in the klr

All the best-Russ
 

·
Registered
Joined
·
15 Posts

·
Registered
Joined
·
15 Posts
I meant the resistance of the bulbs, that's it!!!!

Russ
 
1 - 7 of 7 Posts
Top